
STANDARD PRIMITIVES
 
 
Learning Objectives
After completing this chapter, you will be able to:
• Understand viewport navigation controls
• Understand selection techniques
• Understand Scene Explorer/Layer Explorer
• Create standard primitives
• Render a still image
• Change the background color of a scene

INTRODUCTION
In this chapter, you will learn to create the default 3D objects called standard primitives. These
geometric primitives are parametric objects. Also, you will learn about the viewport navigation
controls and selection techniques.
 
VIEWPORT NAVIGATION CONTROLS
The tools at the lower right corner of the Autodesk 3ds Max screen are known as viewport navigation
controls. These tools are used to control the display and navigation of the viewport.
 
To adjust the view of an object in a viewport, you need to be familiar with the tools in the viewport
navigation controls area. Note that some of the tools mentioned below are available in a flyout which
will be displayed when you click on the arrow on the lower right corner of the tool icon. These tools
are discussed next.
 

The Zoom tool is used to increase or decrease the magnification in the active viewport. You can
zoom in by pressing the left mouse button and dragging the cursor up. Similarly, you can zoom out by
pressing the left mouse button and then dragging the cursor down.
 

The Zoom All tool is the same as the Zoom tool with the only difference that this tool zooms the
display in all four viewports simultaneously.
 
 

The Zoom Extents tool is used to view all objects in the active viewport.
 
 

The Zoom Extents Selected tool is used to view all selected objects in the active viewport.
 



 
The Zoom Extents All tool is the same as the Zoom Extents tool with the only difference that this

tool is used to view all objects in all viewports.
 

The Zoom Extents All Selected tool is the same as the Zoom Extents Selected tool with the only
difference that this tool is used to view all selected objects in all viewports.
 

The Zoom Region tool is used to define the area to be magnified and viewed in the current
viewport. The area to be magnified is specified by a rectangle created by dragging the cursor. The
Zoom Region tool is not available in the Camera viewport.
 

The Field-of-View tool is available only in the Perspective and Camera viewports. It is used to
change the field of view of the scene in these viewports. More the field of view of a camera, more
will be the visibility of the scene, and vice-versa.
 

The Pan View tool is used to pan the scene in the viewport. This tool enables you to display the
contents of the viewport that are outside the display area without changing the magnification of the
current viewport.
 

The 2D Pan Zoom Mode tool is available in Perspective and Camera viewports only. On
invoking this tool you can pan and zoom the scene outside the rendering frame. In other words, the
position of the camera does not change when you pan or zoom in the scene. If the 2D Pan Zoom
Mode tool is chosen, an additional viewport label appears on the right of the other viewport labels.
 

The Walk Through tool is available in Perspective and Camera viewports only. It allows you to
navigate through these viewports by pressing a set of shortcut keys. On invoking this tool, the cursor
changes into a circle with a dot at its center. Press the arrow keys to navigate through the viewport.
On pressing the arrow keys, the cursor shows a directional arrow indicating the navigation direction.
 

The Orbit tool is used to rotate the viewport around its view center. This enables you to see three-
dimensional (3D) view of the objects in the Perspective viewport. You can also rotate the Top, Front,
and Left viewports. But in such cases, the respective viewport becomes the Orthographic viewport.
 

The Orbit Selected tool is the same as the Orbit tool with the only difference that it is used to
rotate the viewport around the center of the current selection.
 

The Orbit SubObject tool is the same as the Orbit tool with the only difference that it is used to
rotate the viewport around the center of the current sub-object selection.
 

The Maximize Viewport Toggle tool is used to maximize the active viewport so that you can
view only the active viewport instead of all the four viewports.



 
The Dolly Camera tool is available in Camera viewport only. It is used to move the camera

toward and away from the target. If the camera passes through the target, the camera flips 180 degrees
and moves away from its target.
 

The Dolly Target tool is only available if viewport’s camera is a target camera. This tool is used
to move the target of the camera towards and away from it. If the target passes through the camera to
the other side, the camera view will be reversed. Otherwise, there will be no visual change in the
camera viewport.
 

The Dolly Camera + Target tool is only available if viewport’s camera is the target camera. This
tool is used to move both the camera and its target.
 

The Roll Camera tool is available in Camera viewport only. It rotates the target camera about its
line of sight, and rotates a free camera about its local Z axis.
 
SELECTION TECHNIQUES
In 3ds Max, you can select objects using various tools such as Select Object, Select by Name,
Select and Move, and so on. These tools are discussed next.
 
Select Object Tool
Quad Menu: Select
Main Toolbar: Select Object
Keyboard: Q

The Select Object tool is used to select one or more objects in the viewport. To select an object,
choose this tool and move the cursor over the object; the cursor will convert into a selection cursor.
Next, press the left mouse button; the object will be selected. To select more than one object at a time,
hold the CTRL key and select the objects that you want to add to the selection. To remove an object
from the selection, press and hold the ALT key and then click on the object that you want to remove
from the selection.
 
Select by Name Tool
Menu bar: Edit > Select By > Name
Main Toolbar: Select by Name
Keyboard: H

The Select by Name tool is used to select an object from the list of objects in the scene. When you
choose the Select by Name tool from the Main Toolbar, the Select From Scene dialog box will be
displayed. If there are some components in the scene, then those components will be displayed in this
dialog box, as shown in Figure 2-1. Now, select an object in the list and choose the OK button.
Alternatively, you can double-click on the object name in the list to select it. You can also select more



than one object by holding the SHIFT or CTRL key. The buttons at the top of the dialog box are used
to filter the objects in the list.

Figure 2-1 The Select From Scene dialog box
 

Select and Move Tool
Quad Menu: Move
Main Toolbar: Select and Move
Keyboard: W

The Select and Move tool is used to select and move the objects in the viewports. You can move
an object by selecting it and then dragging the mouse along the X, Y, or Z axis. You can also move the
selected object in the XY, YZ, or ZX plane. To move the selected object along one of the axes, choose
this tool and then select the object; the move gizmo will be displayed. Move the cursor over the axis
along which you want to move the object, press the left mouse button, and then drag the cursor.
Similarly, to move the object in one of the planes, move the cursor over the plane displayed between
the two axes; the plane will be highlighted in yellow. Next, press the left mouse button and drag the
cursor.
 

 
Select and Rotate Tool
Quad Menu: Rotate
Main Toolbar: Select and Rotate
Keyboard: E

The Select and Rotate tool is used to rotate the objects in the viewport along the X, Y, or Z axis.
To rotate the object along one of the axes, choose the Select and Rotate tool, and then select the
object; a rotate gizmo will be displayed along with the X, Y, and Z axes. Next, move the cursor over
the axes along which you want to rotate the object, press the left mouse button, and then drag the
cursor. When you rotate the object, a transparent slice will be displayed which will provide a visual
representation of the direction and the degree of rotation, refer to Figure 2-2. Also, you can view the
degree of rotation in the X, Y, and Z axes in the coordinates displayed in the Coordinate display area
at the bottom of the screen.



Figure 2-2 The circular gizmo in the Top viewport displayed while rotating the object
 

Select and Scale Tools
Quad Menu: Scale
Main Toolbar: Select and Scale
Keyboard: R
There are three types of tools that are used to scale an object. These tools are available in the Select
and Scale flyout and are discussed next.

Select and Uniform Scale
The Select and Uniform Scale tool is used to scale the objects proportionally along the three

axes. To scale an object uniformly along all the three axes, choose the Select and Uniform Scale tool
from the Main Toolbar and select the object; the scale gizmo will be displayed, as shown in Figure
2-3. Move the cursor to the center of the gizmo and make sure its central portion is highlighted, refer
to Figure 2-3. Next, drag the cursor up or down to scale the selected object. You can also perform
non-uniform scaling using this tool. To do so, move the cursor over the axis along which you want to
scale the object, refer to Figure 2-4, and then drag the cursor. Similarly, you can perform non-uniform
scaling along the XY, YZ, or ZX plane by selecting the required plane and then dragging that plane,
refer to Figure 2-5.
 

Figure 2-3 The scale gizmo for uniform scaling

Figure 2-4 Selecting the Z-axis for non-uniform scaling

Figure 2-5 Selecting the YZ plane for non-uniform scaling
 

Select and Non-uniform Scale Tool
The Select and Non-uniform Scale tool is used to scale an object along a particular axis or plane

non-uniformly. To scale the object, choose the Select and Non-uniform Scale tool from the Select
and Scale flyout, and then select the object. Move the cursor over the X, Y, or Z axis along which you



want to scale the object and drag the cursor to modify the shape of the object. Similarly, you can
perform the non-uniform scaling along the XY, YZ, or ZX plane. You can also perform uniform
scaling in the same manner, as described in the Select and Uniform Scale tool.
 
Select and Squash Tool

The Select and Squash tool is used to stretch and squash the object along the selected axis. To
squash the object along one of the axes, choose the Select and Squash tool and select the object.
Move the cursor over the axis along which you want to squash it. Next, drag the cursor. Similarly, you
can squash the selected object along the XY, YZ, or ZX plane. To do so, move the cursor over the
plane displayed between the two axes and drag the cursor to squash the object along that plane.
 

Note
By default, the color of the X-axis, the Y-axis, and the Z-axis of the transform gizmos is red, green,
and blue, respectively. When you move the cursor over any one of these axes, it gets activated and
turns yellow. You can see the colors of these axes displayed at the bottom left corner of each
viewport. Also, the colored axes are displayed while selecting an object using the Select and
Move, Select and Rotate, or Select and Scale tool. Figures 2-6, 2-7, and 2-8 show the move gizmo,
rotate gizmo, and scale gizmo, respectively.

 

Figure 2-6 The move gizmo

Figure 2-7 The rotate gizmo

Figure 2-8 The scale gizmo
  

Select and Place Tool
In 3ds Max 2015, the Select and Place tool is introduced. This tool is used to position and orient

an object with respect to another object. Using this tool, you can move an object along the surface of
the another object as if it is attracted towards it. Also, the placed object changes its orientation
according to the shape of the object on which it is placed. To place an object on another object,
choose the Select and Place tool from the Main Toolbar and then click and drag the object to the
other object. You will notice that the shape of the cursor has changed, refer to Figure 2-9. When you



are satisfied with the orientation of the object, release the left mouse button; the selected object will
be aligned with the other object, as shown in Figure 2-10.

Figure 2-9 The changed shape of cursor

Figure 2-10 The selected object aligned with other object
 

SCENE MANAGEMENT 
In 3ds Max 2015, the Scene Explorer and Layer Explorer are added which are used to manage
complex scenes in efficient manner. For managing scenes in better way, you can also create and
manage more than one Scene Explorers in a scene. The Scene Explorer can be switched to Layer
Explorer. The Scene Explorer, Layer Explorer, and the procedure of creating and managing more than
one Scene Explorer are discussed next.
 
Scene Explorer
The Scene Explorer is used to view, select, filter, and sort objects. It is also used to rename, delete,
group, freeze, and hide objects. By default, the Scene Explorer is docked on the left in the default
workspace, refer to Figure 2-11.
 

Figure 2-11 The Scene Explorer



 
The options in the Scene Explorer menu bar are used to select objects, customize the Scene Explorer
Toolbar, change the display to specific type of objects in its list, and so on. The Toggle Display
Toolbar button is used to toggle the visibility of the Scene Explorer Toolbar. The Search field is used
to search an object from the list of objects and thereby adding a filter to the list of objects. The
Remove Filter button is used to remove the applied filter. When you right-click in the area where the
list of objects is displayed, a quad menu will be displayed. The options in this quad menu are used to
rename the object, freeze the object, and so on. The name of the workspace used in the scene is
displayed in the field located at the bottom of the Scene Explorer. The arrow at the left of this field is
used to save the active Scene Explorer as the default Scene Explorer, default mass explorer, and so
on. The Sort By Layer button is used to switch the Scene Explorer to Layer Explorer. The Layer
Explorer is discussed next.
 
Layer Explorer
The Layer Explorer will be displayed in the interface on choosing the Sort By Layer button in the
Scene Explorer, refer to Figure 2-11. By default, the Layer Explorer is displayed with a 0 (default)
layer, as shown in Figure 2-12. You can create any number of layers in the Layer Explorer by using
the Create New Layer button. To add an object to the newly created or existing layer, expand the 0
(default) layer and then select the object from the list of objects in the Layer Explorer and right-click
on it; a quad menu will be displayed, refer to Figure 2-13. Choose Add Selection To > New Parent
(pick) from the quad menu and select the desired layer from the list of layers displayed; the selected
object is transferred to the selected layer. You can also create new layer and add the selected object
to it by using the quad menu. To do so, select the object from the list of objects displayed. Next, right-
click on it and then choose Add Selected To > Create Layer from the quad menu displayed; a new
layer will be created and the selected object will be added to it. To rename a layer, right-click on it
and choose Rename from the quad menu displayed.

Figure 2-12 The Layer Explorer



Figure 2-13 The quad menu
 

Creating and Managing the Scene Explorer
In 3ds Max 2015, you can create new Scene Explorer(s) to manage complex scenes. You can open
number of Scene Explorers simultaneously in a scene.
To create a new Scene Explorer, choose Tools > New Scene Explorer
from the menu bar; the Scene Explorer - Scene Explorer # window will
be opened, refer to Figure 2-14. You can close and reopen the Scene
Explorer(s). To reopen the recently closed Scene Explorer, choose Tools >
Open Explorer: Scene Explorer # from the menu bar. Alternatively, you
can press ALT+CTRL+O to reopen it.

To manage various Scene Explorers, choose Tools > Manage Scene
Explorer from the menu bar; the Manage Scene Explorer dialog box will
be displayed, refer to Figure 2-15. Using this dialog box, you can select a
Scene Explorer and set it as a default Scene Explorer. You can also
rename or delete Scene Explorer(s) using this dialog box. You can save a
Scene Explorer for later use in other scenes. To do so, choose the Save
button; the Save Scene Explorer dialog box will be displayed. Next, enter
the desired name in the File name text box and choose Save; the Scene
Explorer is saved with the desired name. To use a saved Scene Explorer in
other scenes, choose the Load button; the Load Scene Explorer dialog
box will be displayed. Select the desired Scene Explorer from this dialog
box and choose Open; the desired Scene Explorer will be opened in the
current scene.



Figure 2-14 The Scene Explorer - Scene Explorer1 window
 

Figure 2-15 The Manage Scene Explorer dialog box
 

AXIS CONSTRAINTS TOOLBAR
The buttons in the Axis Constraints toolbar are used to specify the axis or plane along which the
transformation would be restricted. The transformation includes movement, rotation, and scaling of an
object. The Axis Constraints toolbar is not displayed by default on the interface.
 
To display it, right-click in the blank area on the Main Toolbar; a

Figure 2-16 The Axis Constraints toolbar

shortcut menu will be displayed. Choose Axis Constraints from the shortcut menu; the toolbar will
be displayed on the screen, as shown in Figure 2-16. Now, choose one of the buttons available in the
Axis Constraints toolbar to perform the transformation along the selected axis. You can use the F5,
F6, and F7 function keys to invoke the X, Y, and Z constraints, respectively. To toggle between the
XY, YZ, and XZ axes, you can use the F8 function key.

 
STANDARD PRIMITIVES



Autodesk 3ds Max has several basic three-dimensional geometric shapes which are known as
standard primitives such as box, cone, sphere, cylinder, torus, tube, and so on. You can use these
primitives to create simple 3D models such as a table, box, chair, and so on. All the standard
primitives can be created dynamically using the mouse or by specifying the parameters in the
Keyboard Entry rollout of the Command Panel.
 

To create the standard primitives, choose Create > Geometry in the Command Panel. By default,
the Standard Primitives option is selected in the drop-down list below the Geometry button. Now,
activate the viewport in which you want to create the primitives. Next, choose the corresponding
tool from the Object Type rollout. In the following section, you will learn to create and modify the
standard primitives using various tools available in the Object Type rollout.
 
Creating a Box
Menu bar: Create > Standard Primitives > Box 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Box
To create a box, activate the viewport by clicking in it. Next, choose the Box tool from the Object
Type rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts
will be displayed, as shown in Figure 2-17. Press and hold the left mouse button in the viewport to
specify the first corner of the box and then drag the cursor to define the length and width of the box.
Release the left mouse button to get the desired length and width. Now, move the cursor up or down
to define the height of the box. Click after you get the desired height; the box will be created, as
shown in Figure 2-18.

Figure 2-17 Various rollouts to create a box

Figure 2-18 A box displayed in the viewport



 

Note
1. To view all the rollouts, position the cursor over any rollout until you see the pan icon (hand).
Next, press and hold the left mouse button and drag the cursor in the rollout.
 
2. The plus sign (+) on the left side of the rollout head indicates that the rollout is collapsed and
the minus sign (-) indicates that the rollout is expanded.
 
Tip: If you are creating a standard primitive that requires multiple steps, you can pan or orbit the
viewport between the steps. To pan the viewport, drag the cursor with the middle-mouse button or
mouse wheel held down. To rotate the viewport, press and hold the ALT key and then drag the
cursor with middle-mouse button or mouse wheel held down.
 

 
Various rollouts used to create and modify the box are discussed next.
 
Name and Color Rollout
In Autodesk 3ds Max, a specific name and color is automatically assigned to the newly created box.
To modify this name, expand the Name and Color rollout. Enter a new name in the text box available
in this area and then press ENTER. To change the color of the box, choose the color swatch on the
right side of the edit box; the Object Color dialog box will be displayed, as shown in Figure 2-19.
Choose a new color from this dialog box; the selected color will be displayed in the Current Color
color swatch. Now, choose the OK button; the new color will be assigned to the box.
To customize a color, choose the Add Custom Colors button in the Object Color dialog box; the
Color Selector: Add Color dialog box will be displayed, as shown in Figure 2-20. Now, customize
a new color in this dialog box and choose the Add Color button; the new color will be displayed in
one of the color swatches in the Custom Colors area of the Object Color dialog box. Next, choose
the OK button; the new color will be assigned to the box.
 

Note
The options in the Name and Color rollout are same for all the standard primitives.
 

Figure 2-19 The Object Color dialog box



Figure 2-20 The Color Selector:
Add Color dialog box

 
Creation Method Rollout
The options in this rollout are used for creating the box dynamically using the mouse. By default, the
Box radio button is selected. As a result, you can create a box having different length, width, and
height. Select the Cube radio button to create a box of equal length, width, and height.
 
Keyboard Entry Rollout
This rollout is used to create a box by entering the parameters in the Keyboard Entry rollout using
the keyboard. The Length, Width, and Height spinners are used to specify the length, width, and
height of the box, respectively. The X, Y, and Z spinners to specify the position of the box in the
viewport along the axes of the home grid or of a grid object. By default, the value in these spinners is
0, therefore, the object will be created at the center of the home grid or of a grid object in the
viewport. The Create button in the Keyboard Entry rollout is used to create a box in the viewport of
specified dimensions.
 

Note
1. The grid object is a type of helper object. It is a local grid other than the home grid that you can
create yourself as required
 
2. The Keyboard Entry rollout in all the standard primitives is used to create the corresponding
primitive by entering the parameters in this rollout. The method of creating all primitives is the
same as discussed. The only difference is in the type and number of parameters of various
standard primitives.
 
Parameters Rollout
After creating the box, you can modify its dimensions using the Parameters rollout. The Length,
Width, and Height spinners are used to specify the length, width, and height, respectively of the box.
The Length Segs, Width Segs, and Height Segs spinners are used to define the number of divisions
or segments along each axis of the object. By default, the Generate Mapping Coords. check box is
selected by default. As a result, mapping coordinates are created automatically with a projection
appropriate to the shape of the box. You can select the Real-World Map Size check box to correct
the scale of the texture mapped materials that are applied to the box. This option lets you create a
material and specify the actual width and height of a 2D texture map in the Material Editor.
 

 Note



After creating a primitive in the viewport if you right-click in the viewport to exit the tool, the
Parameters rollout will disappear from the Create tab. In such a case, to modify the parameters of
the primitive, make sure the primitive is selected in the viewport and then choose the Modify tab in
the Command Panel; the Parameters rollout will be displayed in the Modify tab.
 
Creating a Sphere
Menu bar: Create > Standard Primitives > Sphere
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Sphere

To create a sphere, activate a viewport by clicking in it and choose the Sphere tool from the Object
Type rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts
will be displayed, as shown in Figure 2-21. Press and hold the left mouse button to specify the center
of the sphere and then drag the cursor to define the radius of the sphere. Release the left mouse button;
the sphere of the specified radius will be created, as shown in Figure 2-22. Note that the sphere will
be displayed in all viewports.

 
Various rollouts used to create and modify the sphere are discussed next.
 
Creation Method Rollout
The options in this rollout are used for creating a sphere dynamically. By default, the Center radio
button is selected in this rollout. As a result, the starting point is at the center of the sphere. You can
select the Edge radio button to set the starting point on an edge at the surface of the sphere.
 
Parameters Rollout
The options in this rollout are used to modify the parameters of the sphere. The Radius and Segments
spinners are used to specify the radius and divisions, respectively for the sphere. By default, the
Smooth check box is selected, therefore, the sphere appears smooth. If this check box is cleared, it
will give a faceted appearance to the sphere. The Hemisphere spinner is used to create a partial
sphere. By default, the Chop radio button is selected. As a result, the starting point is at the center of
the sphere. If you select the Squash radio button, the hemisphere will have the same number of
vertices and faces as in the complete sphere. On selecting the Slice On check box, the Slice From and
Slice To spinners will be enabled. Set the values in the Slice From and Slice To spinners to specify
the start and end angle to create a partial sphere. By default, the pivot point of the sphere is located at
its center. If you select the Base To Pivot check box, then the pivot point of the sphere will be at its
base.



Figure 2-21 Various rollouts to create a sphere

Figure 2-22 A sphere displayed in the viewport
 

Creating a GeoSphere
Menu bar: Create > Standard Primitives > GeoSphere 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > GeoSphere
The GeoSphere tool creates a more regular surface than the Sphere tool. To create a geosphere,
activate the required viewport and choose the GeoSphere tool from the Object Type rollout; the
Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts will be displayed,
as shown in Figure 2-23. Press and hold the left mouse button to specify the center of the geosphere
and then drag the cursor to define the radius of the geosphere. Next, release the left mouse button to
get the desired radius; a geosphere will be created, as shown in Figure 2-24.
 
Various rollouts used to create and modify the geosphere are discussed next.
 
Creation Method Rollout
The options in this rollout are used for creating a geosphere dynamically. By default, the Center
radio is selected. As a result, the starting point is at the center of the geosphere. You can select the
Diameter radio button to specify the first point on an edge at the surface of the geosphere.
 



Figure 2-23 Various rollouts to create a geosphere

Figure 2-24 A geosphere displayed in the viewport
 

Parameters Rollout
The options in this rollout are used to modify the geosphere. The Radius and Segments spinners are
used to specify the radius and divisions, respectively for the geosphere. By default, the Icosa radio
button is selected in the Geodesic Base Type area. As a result, the surface of the geosphere will
consist of 20-sided polygons and equilateral triangles, as shown in Figure 2-25. You can select the
Tetra radio button in the Geodesic Base Type area, the resulting surface will consist of tetrahedrons
and triangular faces, as shown in Figure 2-26. Similarly, if you select the Octa radio button, you will
get a surface consisting of octagons and triangular faces, as shown in Figure 2-27. By default, the
Smooth check box is selected. As a result, it makes hemisphere smooth. On selecting the
Hemisphere check box, one half of the geosphere will be created. If the Base to Pivot check box is
selected, it will shift the pivot point of the geosphere will be at its base.

Figure 2-25 The geosphere displayed on selecting the Icosa radio button

Figure 2-26 The geosphere displayed on selecting the Tetra radio button



Figure 2-27 The geosphere displayed on selecting the Octa radio button
 
Creating a Cylinder
Menu bar: Create > Standard Primitives > Cylinder 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Cylinder
The Cylinder tool is used to create a cylinder that can be sliced along its major axis. To create a
cylinder, activate the required viewport by clicking in it and choose the Cylinder tool from the
Object Type rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters
rollouts will be displayed, as shown in Figure 2-28.
 
Press and hold the left mouse button to specify the center of the base of the cylinder and then drag the
cursor to define the radius of the cylinder. Release the left mouse button. Next, move the cursor up or
down to define the height of the cylinder. Click after you get the desired height; a cylinder will be
created, as shown in Figure 2-29.

Figure 2-28 Various rollouts to create a cylinder

Figure 2-29 A cylinder displayed in the viewport
 

Various rollouts used to create and modify the cylinder are discussed next.
 
Creation Method Rollout
The options in this rollout are the same as those discussed in the Sphere tool.
 
Parameters Rollout
The options in this rollout are used to modify the cylinder. The Radius spinner is used to set the



radius of the cylinder. The Height spinner is used to specify the height for the cylinder. The value in
the Height Segments spinner defines the number of segments along the height of the cylinder. The
value in the Cap Segments spinner specifies the number of segments at the top and the bottom of the
cylinder. The value in the Sides spinner specifies the number of sides on the cylinder. Different
shapes of the cylinder can be created by entering different values in the Sides spinner. By default, the
Smooth check box is selected, therefore, the cylinder appears smoother. The Slice On check box is
the same as described in the Sphere tool.

 
 
Creating a Cone
Menu: Create > Standard Primitives > Cone 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Cone
The Cone tool is used to create upright or inverted round cones. To create a cone, activate the
viewport and then choose the Cone tool from the Object Type rollout; the Name and Color,
Creation Method, Keyboard Entry, and Parameters rollouts will be displayed, as shown in Figure
2-30.
 
Press and hold the left mouse button to specify the center of the base of the cone and then, drag the
cursor to define radius 1 for base of the cone. Release the left mouse button and move the cursor up or
down to define the height of the cone. Next, click to get the desired height. Move the cursor up or
down again and click to define radius 2 of the cone; a cone will be created, as shown in Figure 2-31.

Figure 2-30 Various rollouts to create a cone

Figure 2-31 A cone displayed in the viewport
 



Various rollouts used to create and modify the cone are discussed next.
 
Creation Method Rollout
The options in this rollout are the same as those discussed in the Sphere tool.

 
Parameters Rollout
The Radius 1 and Radius 2 parameters are used to create pointed or flat-topped cones by specifying
the first and second radii for the cone. The Height spinner is used to specify the height of the cone. If
you specify a negative value for the Height spinner, the cone will be created below the construction
plane.
 
Creating a Tube
Menu bar: Create > Standard Primitives > Tube 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Tube
The Tube tool is used to create round and prismatic tubes. The tube primitive is similar to the
cylinder primitives with a hole in it. To create a tube, activate the required viewport and choose the
Tube tool from the Object Type rollout; the Name and Color, Creation Method, Keyboard Entry,
and Parameters rollouts will be displayed, as shown in Figure 2-32.
 
Press and hold the left mouse button to specify the center of the tube and then drag the cursor to define
the first radius of the tube. It can be the inner or the outer radius of the tube. Next, release the left
mouse button, move the cursor, and then click to define the second radius. Next, move the cursor up or
down and click to get the desired height of the tube; a tube will be created, as shown in Figure 2-33.
 
Various rollouts used to create and modify the tube are discussed next.
 
Creation Method Rollout
The options in this rollout are the same as those discussed in the Sphere tool.
 
Parameters Rollout
The options in this rollout are used to modify the tube. The Radius 1 and Radius 2 spinners are used
to specify the inner and outer radii of the tube. The larger value represents the outer radius while the
smaller value represents the inner radius. The Height spinner is used to specify the height of the tube.
If you specify negative value for this parameter, the tube will be created below the construction plane.
The other options in this rollout are the same as those described in the Cylinder tool.
 
Creating a Torus
Menu bar: Create > Standard Primitives > Torus 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Torus



Figure 2-32 Various rollouts to create a tube

Figure 2-33 A tube displayed in the viewport
 

The Torus tool is used to create doughnut like shapes. To create a torus, activate the required
viewport and choose the Torus tool from the Object Type rollout; the Name and Color, Creation
Method, Keyboard Entry, and Parameters rollouts will be displayed, as shown in Figure 2-34.
 
Press and hold the left mouse button to specify the center of the torus and then drag the cursor to
define the radius of the torus. Release the left mouse button and then drag the cursor to adjust the
radius of the circular cross-section of the torus. Click to get the desired radius; a torus will be
created, as shown in Figure 2-35.

 
Various rollouts used to create and modify the torus are discussed next.
 
Creation Method Rollout
The options in this rollout are the same as those discussed in the Sphere tool.
 
Parameters Rollout
The options in this rollout are used to modify the torus. The Radius 1 spinner is used to specify the
radius for the ring of the torus. Therefore, you can specify the distance from the center of the torus to
the center of the cross-sectional circle in this spinner. By default, the value of the Radius 2 spinner is
set to 10. This spinner specifies the radius of the cross-sectional circle. The value in the Rotation
spinner defines the degree of rotation of the circular cross-section of the torus. The value in the Twist
spinner specifies how much the circular cross-section of the torus can be twisted. The Segments
spinner defines the number of segments around the circumference of the torus. The Sides value



specifies the number of sides in the circular cross-section of the torus. In the Smooth area of the
Parameters rollout, there are four radio buttons. By default, the All radio button is selected. As a
result, smoothness is applied to all surfaces of the torus. You can select the Sides radio button to
apply smoothness between adjacent segments. If you select the Segments radio button, smoothness is
applied to the segments individually. It results in the formation of ring-like segments along the torus.
Select the None radio button, if you do not want to apply smoothness to the torus. The function of the
Slice On check box is the same as described for the Sphere tool.

Figure 2-34 Various rollouts to create a torus

Figure 2-35 A torus displayed in the viewport
 

Creating a Pyramid
Menu bar: Create > Standard Primitives > Pyramid 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Pyramid
To create a pyramid, activate the viewport and choose the Pyramid tool from the Object Type
rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts will be
displayed, as shown in Figure 2-36.
 
Press and hold the left mouse button to specify the first corner of the pyramid and then drag the cursor
to define the width and depth of the pyramid. Release the left mouse button and drag the cursor
upward. Click after you get the desired height; a pyramid will be created, as shown in Figure 2-37.



Figure 2-36 Various rollouts to create a pyramid

Figure 2-37 A pyramid displayed in the viewport
 

Various rollouts used to create and modify the pyramid are discussed next.
 
Creation Method Rollout
The options in this rollout are used for creating a pyramid dynamically. By default, the Base/Apex
radio button is selected. As a result, the first point is specified as the first corner of the base of the
pyramid. You can select the Center radio button to specify the first point as the center of the base of
the pyramid.
 
Parameters Rollout
The options in this rollout are used to modify the pyramid. The Width, Depth, and Height spinners
are used to specify the width, depth, and height, respectively of the pyramid. The values in the Width
Segs, Depth Segs, and Height Segs spinners define the number of segments on the corresponding
sides of the pyramid.
 
Creating a Plane
Menu bar: Create > Standard Primitives > Plane 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Plane
To create a plane, activate the required viewport and then choose the Plane tool from the Object
Type rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts
will be displayed, as shown in Figure 2-38.
 
Press and hold the left mouse button to specify the first corner of the plane and then drag the cursor to



define the length and width of the plane. Release the left mouse button; a plane will be created, as
shown in Figure 2-39.

Figure 2-38 Various rollouts to create a plane

Figure 2-39 A plane displayed in the viewport
 
Various rollouts used to create and modify the plane are discussed next.
 
Creation Method Rollout
The options in this rollout are used for creating a plane dynamically. By default, the Rectangle radio
button is selected. As a result, the first point is specified as the corner of a rectangular plane. You can
select the Square radio button to specify the first point as the center of a square plane. Note that in the
case of a square plane, the length and width of the plane will be equal.
 
Parameters Rollout
The options in this rollout are used to modify the plane. The Length and Width spinners are used to
specify the length and width, respectively of the plane. The values in the Length Segs and Width
Segs spinners define the number of segments along the length and width of the plane, respectively.
The Render Multipliers area is used to set the multipliers for rendering. The Scale spinner is used to
specify the value by which the length and width will be multiplied at rendering. The Density spinner
is used to specify the value by which the number of segments along the length and width will be
multiplied at rendering.
 
Creating a Teapot
Menu bar: Create > Standard Primitives > Teapot 
Command Panel: Create > Geometry > Standard Primitives >
Object Type rollout > Teapot
To create a teapot, activate the required viewport and choose the Teapot tool from the Object Type
rollout; the Name and Color, Creation Method, Keyboard Entry, and Parameters rollouts will be
displayed, as shown in Figure 2-40.



 
Press and hold the left mouse button to define the center of the bottom face and then drag the cursor to
define the radius of the teapot. Release the left mouse button after you get the desired radius; a teapot
will be created with the pivot point at the center of its base, as shown in Figure 2-41.

Figure 2-40 Various rollouts to create a teapot

Figure 2-41 A teapot displayed in the viewport
 

Various rollouts used to create and modify the teapot are discussed next.
 
Creation Method Rollout
The options in this rollout are the same as those discussed in the Sphere tool.
 
Parameters Rollout
The options in this rollout are used to modify the teapot. The Radius spinner is used to specify the
overall size of the teapot. Therefore, it specifies the distance from the center of the teapot to the body
parameter. The Segments spinner is used to specify the number of divisions in each quadrant of the
body. By default, the Smooth check box is selected. Therefore, all parts of the teapot will be
smoothened. A teapot has four parts: body, handle, spout, and lid. If you want to remove any one of
the parts, clear the check box corresponding to that part in the Teapot Parts area of the Parameters
rollout. You can also use different parts of a teapot individually to make another object. For example,
you can use the handle of the teapot for creating a coffee mug.
 
RENDERING A STILL IMAGE
Menu bar: Rendering > Render 
Toolbar: Main Toolbar > Render Production
Keyboard: SHIFT + Q
Rendering is a process of generating a 2D image from a 3D scene. It shows the lighting effects,
materials applied, background, and other settings that you have applied to the scene. The basic
rendering for a still scene is discussed next while the advance rendering for the animated scenes will



be discussed in the later chapters.
 

To render a still image, activate the viewport and choose the Render Setup
tool from the Main Toolbar; the Render Setup: Default Scanline Renderer
dialog box will be displayed. The Common tab is chosen by default in this
dialog box. In the Common Parameters rollout, make sure that the Single radio
button is selected in the Time Output area. This will enable you to render a
single frame at a time. In the Output Size area, set the parameters or use the
default ones and then choose the Render button at the lower right corner in the
dialog box; the rendered image will be displayed in the Perspective, frame 0,
Display Gamma:2.2, RGBA Color16 Bits/Channel (1:1) window, as shown in
Figure 2-42.

 
Figure 2-42 The Perspective, frame 0, RGBA Color16 Bits/Channel (1:1) window

 
Here, Perspective refers to the name of the viewport that you have selected at rendering and frame 0
refers to the number of frame that has been rendered.
 

Note
To render a view quickly, choose the Render Production tool from the Main Toolbar or press the
F9 key.
 
To save the rendered image, choose the Save Image button in the Perspective, frame 0, Display
Gamma:2.2, RGBA Color 16 Bits/Channel (1:1) window; the Save Image dialog box will be
displayed. Now, select the type of image format from the Save as type drop-down list and enter the
name of the image in the File name text box. Next, browse to the folder where you want to save the
scene and choose the Save button; a dialog box will be displayed. You can adjust the settings for the
file format you have chosen in this dialog box. Use the default settings and choose the OK button; the
image file will be saved at the selected location.
 

Note
In later chapters, the Perspective, frame 0, Display Gamma:2.2, RGBA Color16 Bits/Channel
(1:1) window is referred to as the Rendered Frame window.
 
Quicksilver Hardware Renderer
By default, a 3ds Max scene is rendered using the Scanline renderer. However, if you choose the



Quicksilver hardware renderer, you can achieve various rendering styles such as wireframe
rendering, clay rendering, non-photorealistic rendering, and so on. To do so, you need to follow the
steps given next.
 
1. Activate any of the viewport and choose the Render Setup tool from the Main Toolbar; the

Render Setup: Default Scanline Renderer dialog box will be displayed. The Common tab is
chosen by default in this dialog box.

 
2. Collapse the Common Parameters rollout in this tab and expand the Assign Renderer rollout. In

this rollout, choose the Choose Renderer button at the right of the Production text box; the Choose
Renderer dialog box will be displayed. Select the Quicksilver Hardware Renderer option and
choose the OK button to exit the Choose Renderer dialog box. Notice the change in the Render
Setup dialog box.

 
3. Choose the Renderer tab; various rollouts will be displayed, refer to Figure 2-43. In the Visual

Style area of the Visual Style & Appearance rollout, various options are available in the
Rendering Level drop-down list, as shown in Figure 2-44.

 
4. To change the rendering style, you can select the required option from the Rendering Level drop

down list. Next, choose the Render button at the lower right corner of the dialog box; the rendered
image will be displayed as per the option selected in the drop-down list.

NVIDIA iray Renderer
The NVIDIA iray renderer creates physically accurate renderings by tracing the light paths. The
performance of the renderer can be improved if the system is equipped with a graphics card having a
CUDA (Compute Unified Device Architecture) enabled Graphic Processing Unit (GPU).
 
When you change the current renderer to the NVIDIA iray renderer using the Render Setup dialog
box, the iray, Advanced Parameters, Displacement Parameters, Hardware Resources, and
Motion Blur rollouts will be displayed in the Render Setup dialog box. The procedure to change the
renderer has been explained in detail in the previous section. Figure 2-45 shows the iray rollout in
the Render Setup dialog box. It has three radio buttons namely: Time, Iterations, and Unlimited. By
selecting the Time radio button, you can specify the duration of the rendering. By selecting the
Iterations radio button, you can specify the number of iterations (passes) to be computed before
showing the final render. If the Unlimited radio button is selected, rendering will continue for
indefinite time and stops when satisfactory quality of rendering is achieved. The rendering done by
the iray renderer appears more grainy in the first few passes. The graininess decreases as you
increase the number of passes. The NVIDIA iray renderer renders glossy reflections and self
illuminating objects with much more precision as compared to the other renderers. However, this
renderer supports only certain materials, maps, and shader types.



Figure 2-43 The Render Setup: Quicksilver Hardware Renderer dialog box

Figure 2-44 The Rendering Level drop-down list
 

Changing the Background Color
Menu bar: Rendering > Environment 
Keyboard: 8
By default, the background color of the final output is black at the time of rendering. To change the
background color, choose Rendering > Environment from the menu bar; the Environment and
Effects dialog box will be displayed, as shown in Figure 2-46. In this dialog box, the Environment
tab is chosen by default. The Common Parameters, Exposure Control, and Atmosphere rollouts
will be displayed under this tab. In the Common Parameters rollout, the Background area is used to
change the background color of the scene on rendering. In the Background area, choose the color
swatch corresponding to the Color parameter; the Color Selector: Background Color dialog box
will be displayed. Select a new color and choose the OK button. Next, close the Environment and
Effects dialog box; the background will display the new color on rendering.

Figure 2-45 The iray rollout in the Render Setup dialog box



Figure 2-46 The Environment and Effects dialog box
 
 

 
TUTORIALS
Tutorial 1
In this tutorial, you will create 3D model of a table with drawers, as shown in Figure 2-47, by using
the standard primitives. (Expected time: 30 min)

 

Figure 2-47 The model of a table with drawers
 

The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create left and right boxes of table.
c. Align boxes.
d. Create the drawer.
e. Create clones of the drawer.
f. Create outer faces of the table.
g. Create knobs for drawers of the table.
h. Change background color of the scene.
i. Save and render the scene.
 
Creating the Project Folder
Before starting a new scene, it is recommended that you create a project folder. Creating a project



folder helps you keep all files of a project in an organized manner. Open the Windows Explorer and
browse to the Documents folder. In this folder, create a new folder with the name 3dsmax2015. The
3dsmax2015 folder will be the main folder and it will contain all the project folders that you will
create while doing tutorials of this textbook. Now, you will create first project folder for Tutorial 1 of
this chapter. To do so, you need to follow the steps given next:
 
1. Start Autodesk 3ds Max 2015.
 
2. If 3ds Max is already running, you need to reset it. To do so, choose Reset from the Application

menu. If the current work is not saved, the Autodesk 3ds Max 2015 message box is displayed.
Next, choose the desired option from this message box; the 3ds Max message box is displayed.
Choose the Yes button from the message box; a new screen is displayed with default settings.

 

Note
The Reset option is used to reset 3ds Max settings such as viewport configuration, snap settings,
the Material Editor dialog box, background image, and so on. It also restores the startup defaults.
 
3. Choose the Application button; the Application menu is displayed. Next, choose Manage > Set

Project Folder from it; the Browse For Folder dialog box is displayed.
 
4. In the Browse For Folder dialog box, navigate to \Documents\3dsmax2015. Next, choose the

Make New Folder button to create a new folder with the name c02_tut1. Next, choose the OK
button to close the Browse For Folder dialog box.

 
5. Choose Save from the Application menu; the Save File As dialog box is displayed.
 

Note
The scenes created in 3ds Max are saved with the .max extension. As the project folder is already

created, the path \Documents\3dsmax2015\c02_tut1\scenes is displayed in the Save in drop-
down list of the Save File As dialog box.

Tip: After setting the project when you open or save a scene, 3ds Max uses the scenes folder inside
the project folder by default.

 
6. Enter c02tut1 in the File name edit box and then choose the Save button to close the dialog box.
 

Note
1. When you start 3ds Max, the last project that you have worked with is opened and an empty

scene is created with the name Untitled.
 
2. You can also save a scene in the previous versions (2012 to 2014) of 3ds Max. To do so, select



the desired option from the Save as type drop-down in the Save File As dialog box.
 
3. It is recommended that you frequently save the files while you are working on them by pressing

the CTRL+S keys.

Autodesk 3ds Max creates a backup of the scene and saves changes periodically. In case of system
failure, you can open the auto backup scene file and continue working on it. If you have not created
the project folder on Windows 7, the default path to save the auto backup file is as follows:
C:\users\<username>\My Documents\3dsmax\autoback. However, if you have created the
project folder, the backup file will be saved in the autoback subfolder of the project folder. When
3ds Max is saving a file, the information, “Autosave in progress... (Press ESC to cancel)” is
displayed in the prompt line at the bottom of the interface. If the size of the file is too large and it is
taking time to save, you can press ESC to interrupt the saving process. You can also set the number
of autoback files, their names, and backup time interval. To do so, choose Customize >
Preferences from the menu bar; the Preferences Settings dialog box will be displayed. Next,
choose the Files tab and then set the options as required in the Auto Backup area of dialog box.

 
Creating Left and Right Boxes of Table
In this section, you need to create the basic shape of table. You will use the Box tool from standard
primitives to create the shape.
 
1. Choose Create > Geometry in the Command Panel; Standard Primitives is displayed in the

drop-down list below the Geometry button. Also, the Object Type rollout is displayed in the
Command Panel. Next, choose the Box tool from the Object Type rollout.

 
2. Activate the Top viewport. Press and hold the left mouse button at the upper left corner of the

viewport, drag the cursor to the lower right corner and then release the left mouse button to set the
length and width of the box. Next, move the mouse in the upward direction and click in the
viewport to set the height of the box.

 
3. In the Parameters rollout, enter the values as given below:
 
Length: 90 Width: 75 Height: 95
 
4. Choose the Zoom Extents All tool from the viewport navigation controls to view the box; the

box is displayed in all viewports, as shown in Figure 2-48.



Figure 2-48 The box displayed in viewports
 
5. In the Name and Color rollout, enter left box and press ENTER; the object is named as left box.
 
6. Choose the color swatch in the Name and Color rollout to change the color of left box; the Object

Color dialog box is displayed. Choose the Add Custom Colors button from this dialog box; the
Color Selector: Add Color dialog box is displayed. In this dialog box, enter the values as given
next:

 
Red: 224 Green: 143 Blue: 87
 
7. Choose the Add Color button in the Color Selector: Add Color dialog box; the selected color is

displayed in one of the color boxes in the Custom Colors area of the Object Color dialog box.
Choose the OK button in the Object color dialog box to apply the color to left box.

 
8. Create another box in the Top viewport by using the methods described earlier. Enter the following

values in the Parameters rollout:
 
Length: 90 Width: 80 Height: 25
 
9. In the Name and Color rollout, enter right box and press ENTER; the object is named as right

box. Also, assign the same color to right box that you assigned to left box, refer to steps 6 and 7.
 
Aligning Boxes
In this section, you will align the left and right boxes together.
1. Choose the Select and Move tool and make sure right box is selected. Move right box along the

X, Y, and Z axes in all viewports to align it with left box, as shown in Figure 2-49. Click in the
viewport and choose the Zoom Extents All tool from the viewport navigation controls to view the
box in all viewports, refer to Figure 2-49.



Figure 2-49 Alignment of left box with right box in viewports
 

Note
While aligning the objects, you need to make sure that the objects are aligned properly in all
viewports.
 
Creating the Drawer
In this section, you will create drawers of the table and then clone the drawers.
 
1. Create another box in the Top viewport and enter the following values in the Parameters rollout:
 
Length: 90 Width: 55 Height: 25
 
2. In the Name and Color rollout, enter drawer001 and press ENTER; the object is renamed. Choose

the color swatch to change the color of drawer001; the Object Color dialog box is displayed.
Choose the Add Custom Colors button; the Color Selector: Add Color dialog box is displayed. In
this dialog box, specify the values as given below:

 
Red: 177 Green: 88 Blue: 27
 
3. Choose the Add Color button from the Color Selector: Add Color dialog box to add the selected

color. The color is displayed in one of the Custom Color boxes in the Object Color dialog box.
Choose the OK button; the new color is assigned to drawer001.

4. Align drawer001 with left box in viewports using the Select and Move tool, as shown in Figure
2-50.



Figure 2-50 Alignment of drawer001 with left box
 

Creating Clones of the Drawer
In this section, you will create copies of drawer001.

1. Activate the Front viewport and make sure drawer001 is selected. Next, move the cursor over the
Y axis, press and hold the SHIFT key, and drag drawer001 downward until the value in the Y
spinner of the Coordinate display at the bottom of the screen becomes around -29. Release the left
mouse button and the SHIFT key; the Clone Options dialog box is displayed, as shown in Figure 2-
51.

Figure 2-51 The Clone Options dialog box
 

2. Make sure the Copy radio button is selected in the Object area of the Clone Options dialog box.
In the Number of Copies spinner, enter 2 to create two copies of drawer001. Next, choose the OK
button; two drawers with same dimensions are created, as shown in Figure 2-52.

Figure 2-52 The drawer002 and drawer003 geometry created after cloning drawer001
 



Note
The cloned objects are automatically named sequentially as drawer002 and drawer003, based on
the name of the original object. You can also clone an object by holding the SHIFT key while
rotating or scaling it.
 
3. Create another box in the Top viewport and in the Parameters rollout, enter the values as follows:
Length: 90 Width: 70 Height: 17
 
4. Name the newly created box as drawer004 and change its color as you did for the drawers created

previously.
 
5. Align drawer004 with the right box in viewports, as shown in Figure 2-53.

 
Creating Outer Faces of the Table
In this section, you will create outer faces of the table to make it appear more realistic.
 
1. Create a box in the Left viewport and in the Parameters rollout, enter the values given below:
 
Length: 95.5 Width: 90 Height: 1.5

Figure 2-53 Alignment of drawer004 in all viewports

2. In the Name and Color rollout, enter left face001 and press ENTER; the box is named as left
face001. Choose the color swatch to change the color of left face001; the Object Color dialog box
is displayed. Choose the Add Custom Colors button from this dialog box; the Color Selector: Add
Color dialog box is displayed. Enter the following values in the dialog box:

 
Red: 134 Green: 59 Blue: 8
 
3. Choose the Select and Place tool from the Main Toolbar. In the Perspective viewport, move

the cursor over left face001 and drag to align it with the left side of left box, as shown in Figure 2-
54.

 



4. In the Front viewport, copy left face001 by using the Clone Options dialog box as described
earlier; a new face is created with the name left face002. Now, align it with the other side of left
box, as shown in Figure 2-55.

Figure 2-54 Alignment of left face001 with left side of the left box
 

Figure 2-55 Alignment of left face002
 

5. To create the upper face of the table, create another box in the Top viewport using the values given
below:

 
Length: 90.5 Width: 158.116 Height: 1.5
6. Name the box as upper face and assign the same color to it as assigned to the other faces.
 
7. Align upper face with the top of the table, as shown in Figure 2-56.

 
 

Figure 2-56 Alignment of upper face with top of the table
 



8. Create one more box in the Top viewport using the values given below:
 
Length: 90.5 Width: 77 Height: 1.5
 
9. Name the box as lower face and assign it same color as assigned to other faces.
 
10. Align lower face with the bottom of left box, as shown in Figure 2-57.

 
11. Create another box for the lower face of right box in the Top viewport using the following

dimensions:
 
Length: 90.5 Width: 80 Height: 1.5
 
12. Name the box as right lower face and assign the same color to it as assigned to the other faces.
 
13. Align right lower face at the bottom of right box, as shown in Figure 2-58.

 
14. Create a box for the right face of right box in the Left viewport using the following dimensions:
 
Length: 27.5 Width: 90 Height: 1.5

Figure 2-57 Alignment of lower face with the bottom of left box
 

Figure 2-58 Alignment of right lower face at the bottom of right box of the table



 
15. Name the box as right face and assign the same color to it as assigned to the other faces.
 
16. Align right face with the right side of right box, as shown in Figure 2-59.
 

Figure 2-59 Alignment of right face with the right side of right box of the table
 

Creating Knobs for Drawers of the Table
In this section, you will create a knob for one drawer. Next, you will copy the knob for the other
drawers.
 
1. Choose the Sphere tool from Create > Geometry > Standard Primitives > Object Type rollout

of the Command Panel.
 
2. Create a sphere in the Front viewport. In the Parameters rollout, enter 2.3 in the Radius spinner.

Also, make sure the Smooth and Generate Mapping Coords check boxes and the Chop radio
button are selected in this rollout.

3. Name the sphere as knob001 and use the color swatch to change its color to white.
 
4. Align knob001 with drawer001 in all viewports using the Select and Move tool, as shown in

Figure 2-60.
 

5. Activate the Front viewport and then create three copies of knob001 by using the Clone Options
dialog box as described earlier. The newly created copies are automatically named as knob002,
knob003, and knob004. Next, align them in viewports, as shown in Figure 2-61.



Figure 2-60 Alignment of knob001 with drawer001
 

Figure 2-61 Alignment of knobs in viewports
 

6. Set the view of the table in the Perspective viewport using the Orbit tool from the viewport
navigation controls.

Changing Background Color of the Scene
In this section, you will change background color of the scene.
 
1. Choose Rendering > Environment from the menu bar; the Environment and Effects dialog box is

displayed with the Environment tab chosen by default in this dialog box.
2. In the Background area of the Common Parameters rollout, choose the color swatch

corresponding to the Color parameter; the Color Selector: Background Color dialog box is
displayed. Select the white color and choose the OK button.

 
3. Close the Environment and Effects dialog box.
 
Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can also view the
final rendered image of this model by downloading the c02_3dsmax_2015_rndr.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds
Max > Autodesk 3ds Max 2015: A Comprehensive Guide



 
1. Choose Save from the Application menu.
 
2. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the Rendered Frame window is displayed with the final output of the table, as shown in
Figure 2-62.

 
 

Figure 2-62 The final output after rendering
 

Tutorial 2
In this tutorial, you will create the 3D model of a park bench, as shown in Figure 2-63, using standard
primitives. (Expected time: 90 min)
 
The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create horizontal back supports.
c. Group horizontal back supports.
d. Create horizontal seat supports.
e. Group horizontal Seat Supports
f. Create vertical back supports.
g. Create rivets for the horizontal back support.
h. Align rivets .
i. Create right side rivets.
j. Rotate the back support.
k. Create leg supports.
l. Create rivets for the seat support.
m. Create legs of the park bench.
n. Save and render the scene.



Figure 2-63 The model of a park bench
 

Creating the Project Folder
Create a new project folder with the name c02_tut2 at \Documents\3dsmax2015 and then save the
file with the name c02tut2, as discussed in Tutorial 1.
 
Creating Horizontal Back Supports
In this section, you need to create horizontal back supports of the park bench.
 
1. Activate the Top viewport. Choose Create > Geometry in the Command Panel; Standard

Primitives is displayed in the drop-down list. Next, choose the Box tool from the Object Type
rollout; various rollouts are displayed in the Command Panel.

 
2. Expand the Keyboard Entry rollout and set the values as given below:
Length: 1.5 Width: 124 Height: 6.03
 
3. Choose the Create button from the Keyboard Entry rollout; a box is created in viewports, refer to

Figure 2-64.
 
4. In the Name and Color rollout, name the box as horizontal back support001 and press the ENTER

key.

Figure 2-64 A box created
 

5. Choose the color swatch from the Name and Color rollout; the Object Color dialog box is
displayed. Now, using this dialog box, modify the color of horizontal back support001 to light
brown. Choose the OK button to close the Object Color dialog box.

 
Next, you need to create copies of horizontal back support001.



 
6. Activate the Front viewport. Choose the Select and Move tool from the Main Toolbar and make

sure that horizontal back support001 is selected. Next, move the cursor over the Y axis. Press and
hold the SHIFT key and the left mouse button. Now, drag horizontal back support001 upward until
the value in the Y spinner in the Coordinate display becomes around 8.0. Release the left mouse
button and the SHIFT key; the Clone Options dialog box is displayed.

 
7. In the Clone Options dialog box, make sure the Copy radio button is selected. Set the value in the

Number of Copies spinner to 4. Choose the OK button; four boxes with the same dimensions are
displayed and they are automatically named as horizontal back support002, horizontal back
support003, horizontal back support004, and horizontal back support005.

 
8. Choose the Zoom Extents All tool from the viewport navigation controls; the horizontal back

supports are displayed in viewports, as shown in Figure 2-65.
 

Next, you need to rotate horizontal back support005.
 

9. Activate the Left viewport and select horizontal back support005. Next, right-click on the Select
and Rotate tool in the Main Toolbar; the Rotate Transform Type-In dialog box is displayed.

Figure 2-65 Horizontal back supports displayed in viewports
 

10. In the Absolute:World area, set the value -10 in the X spinner, as shown in Figure 2-66 and then
press the ENTER key; horizontal back support005 gets rotated, refer to Figure 2-67. Now, close
the Rotate Transform Type-In dialog box.

 
11. Click anywhere in the viewport to deselect horizontal back support005.
 
Grouping Horizontal Back Supports
In this section, you will group all horizontal seat supports.
 
1. Activate the Left viewport and choose the Select Object tool. Now, select all horizontal back

supports by dragging a selection box around them, refer to Figure 2-68.



 

Figure 2-66 The Rotate Transform Type-In dialog box

Figure 2-67 The horizontal back support005
geometry after rotating in the Left viewport

 
2. Choose Group > Group from the menu bar; the Group dialog box is displayed.
 
3. In the Group name text box, enter horizontal back support, as shown in Figure 2-69 and then

choose the OK button; all horizontal back supports are grouped together.
Figure 2-68 All horizontal back supports selected simultaneously

Figure 2-69 The Group dialog box
 

Creating Horizontal Seat Supports
In this section, you will create horizontal seat supports.
 
1. Activate the Top viewport and choose the Box tool from the Object Type rollout.
 
2. Expand the Keyboard Entry rollout and set the values as follows:
Length: 6.03 Width: 124 Height: 1.5
 
3. Choose the Create button from the Keyboard Entry rollout; a box is created in all viewports.
 
4. In the Name and Color rollout, name the box as horizontal seat support001.
 
5. Use the color swatch to assign the same color to horizontal seat support001 that you assigned to



horizontal back support.
 
6. Choose the Select and Move tool from the Main Toolbar and align horizontal seat support001

with horizontal back support in viewports, refer to Figure 2-70.
Next, you need to create four copies of horizontal seat support001.

 
7. Activate the Top viewport and make sure horizontal seat support001 is selected. Next, place the

cursor over the vertical axis. Press and hold the SHIFT key and drag horizontal seat support001
downward until the value in the Y spinner in the Coordinate display becomes around -7.5. Release
the left mouse button and the SHIFT key; the Clone Options dialog box is displayed.

 
8. In the Clone Options dialog box, make sure the Copy radio button is selected. Set the value in the

Number of Copies spinner to 4 and choose the OK button; four boxes with the same dimensions
are displayed and they are automatically named as horizontal seat support002, horizontal seat
support003, horizontal seat support004, and horizontal seat support005.

Figure 2-70 Alignment of horizontal seat support001 in viewports
 

9. Choose the Zoom Extents All tool; all objects are displayed in the viewports, as shown in Figure
2-71.

Figure 2-71 Horizontal seat supports displayed in the viewports
10. Click anywhere in the viewport to deselect the objects.



 
Grouping Horizontal Seat Supports
In this section, you will group all horizontal seat supports using the Scene Explorer.
1. Select all horizontal seat supports from the list displayed in the Scene Explorer using the CTRL key

and then right-click; a quad menu is displayed.
 
2. Choose Add Selected to > New Group from this quad menu; the Group dialog box is displayed.

 
3. In the Group name text box, enter horizontal seat support and then choose the OK button.
 
Creating Vertical Back Supports
In this section, you will create vertical back supports of the park bench.
 
1. Activate the Top viewport. Choose Create > Geometry in the Command Panel; Standard

Primitives is displayed in the drop-down list. Next, choose the Cylinder tool in the Object Type
rollout.

 
2. In the Keyboard Entry rollout, set the values as follows:
 
X: -60 Y: 1.5 Z: 0.0
Radius: 1.0 Height: 38.0
 
3. Now, choose the Create button in the Keyboard Entry rollout; a cylinder is created in all

viewports, as shown in Figure 2-72.
 

4. In the Name and Color rollout, name the cylinder as vertical back support001 and press the
ENTER key.

 
5. Change the color of vertical back support001 to black.
 
Next, you need to create a copy of vertical back support001.

6. Activate the Front viewport by middle-clicking in it. Choose the Select and Move tool and move
the cursor over the horizontal axis. Press and hold the SHIFT key and the left mouse button, and
then drag vertical back support001 to the right side to align it with the right side of horizontal
back support, as shown in Figure 2-73. Release the left mouse button and the SHIFT key; the Clone
Options dialog box is displayed.

 
7. In the Clone Options dialog box, make sure the Copy radio button is selected. Set the value 1 in

the Number of Copies spinner and choose the OK button; vertical back support002 is created
with the same dimensions as vertical back support001, refer to Figure 2-73.

 
8. Click anywhere in the viewport to deselect the objects.



Figure 2-72 The vertical back support001 geometry in viewports
 

Figure 2-73 The vertical back support002 in viewports
 

Creating Rivets for Horizontal Back Support
In this section, you will create a sphere and a cylinder to create the cap and the body of rivet,
respectively.

1. Activate the Top viewport and choose Create > Geometry in the Command Panel; Standard
Primitives is displayed in the drop-down list. Next, choose the Sphere tool in the Object Type
rollout.

 
2. In the Keyboard Entry rollout, set the value 0.8 in the Radius spinner and choose the Create

button; a sphere is created.

3. In the Parameters rollout, make sure that the Smooth check box and the Chop radio button are
selected. In the Hemisphere spinner, enter the value 0.5.

4. Name the sphere as cap and assign black color to it.
 
Next, you need to create a cylinder for the body of the rivet.
 
5. In the Command Panel, choose Create > Geometry > Standard Primitives > Object Type



rollout > Cylinder.
 
6. In the Keyboard Entry rollout, set the values as follows:

X: 0 Y: 0 Z: 0
Radius: 0.241 Height: 3.5
 
7. Choose the Create button from the Keyboard Entry rollout; a cylinder is created.

8. Name the cylinder as body and assign black color to it.
 

9. Activate the Left viewport and select cap and body simultaneously from the Scene Explorer by
holding the CTRL key; cap and body are selected in the viewports.

 
10. Choose the Zoom Extents All Selected tool to increase the magnification of the selected objects

in all viewports.
 
11. Next, align cap and body of the rivet in the Left viewport using the Select and Move tool, as

shown in Figure 2-74.

Note
You may need to use the Zoom and Pan View tools to align cap and body of the rivet.
 
Next, you need to group body and cap to create the rivet.
 
12. Select cap and body of the rivet in the Scene Explorer and group them as rivet001.
 
13. Choose the Zoom Extents All tool and move rivet001 in the Left viewport to visualize it

properly, as shown in Figure 2-75.

Figure 2-74 Alignment of cap and body

Figure 2-75 The rivet001 group in the Left viewport



 
Aligning Rivets
In this section, you will align rivets.
1. In the Left viewport, select rivet001 and right-click on the Select and Rotate tool; the Rotate

Transform Type-In dialog box is displayed. Also, a circular gizmo along with the X, Y, and Z axes
is displayed.

 
2. In the Offset:Screen area of the Rotate Transform Type-In dialog box, enter -90 in the Z spinner

and press ENTER; rivet001 gets rotated, as shown in Figure 2-76. Now, close the Rotate
Transform Type-In dialog box.

Figure 2-76 Rotating rivet001 in the Left viewport
 
3. Choose the Select and Move tool and align rivet001 with horizontal back support in all

viewports, as shown in Figure 2-77.
 
4. In the Left viewport, select rivet001 using the Select and Move tool and move the cursor over the

vertical axis. Now, create 4 copies of rivet001. These copies are automatically named as rivet002,
rivet003, rivet004, and rivet005. Align them in the Left viewport, refer to Figure 2-78.

 
5. Select the uppermost rivet and choose the Select and Rotate tool. Now, rotate the uppermost rivet

by using the outermost ring of the Select and Rotate tool in the counterclockwise direction until
the value in the X spinner in the coordinate display becomes -15, refer to Figure 2-79. Next, align it
using the Select and Move tool.

Figure 2-77 Alignment of rivet001 with horizontal back support
 



Figure 2-78 Alignment of rivets in the Left viewport

Figure 2-79 Rotating uppermost rivet
 
6. Press and hold the CTRL key and select all rivets from the Scene Explorer and group them as left

side rivets. Click anywhere in the viewport to deselect the objects.
 

Note
To change the viewport without deselecting the objects, middle-click in that viewport; the objects
will remain selected.
 
Creating Right Side Rivets
In this section, you will copy left side rivets for creating right side rivets.
 
1. Select left side rivets in the Front viewport using the Select and Move tool and move the cursor

over the horizontal axis. Next, press and hold the SHIFT key and the left mouse button, and then
drag the mouse toward the right side. Release the left mouse button and the SHIFT key exactly over
vertical back support002 on the right side; the Clone Options dialog box is displayed.

 
2. In the Clone Options dialog box, make sure the Copy radio button is selected. In the Name text

box, enter right side rivets to modify the name of the group and choose OK; right side rivets group
is displayed, as shown in Figure 2-80.

Figure 2-80 The right side rivets group displayed in viewports



 
Now, you need to select horizontal back support, vertical back support001, vertical back

support002, left side rivets, and right side rivets.
 
3. Select horizontal back support, vertical back support001, vertical back support002, left side

rivets, and right side rivets using the CTRL key from the Scene Explorer and then group them as
back support as described earlier.

 
Rotating the Back Support
In this section, you will rotate the back support.
 
1. Select back support in the Left viewport and choose the Select and Rotate tool; a circular gizmo

is displayed.

2. Move the cursor over the Z-axis, which is blue in color; the Z-axis turns yellow and becomes
active. Now, press the left mouse button and drag the cursor counterclockwise to rotate the back
support until the value in the Z spinner in the coordinate display becomes around 10.

Release the left mouse button; the back support group is rotated, as shown in Figure 2-81.

3. Choose the Select and Move tool and align back support with horizontal seat support, as shown
in Figure 2-82.

 

Figure 2-81 Rotating back support in the Left viewport

Figure 2-82 Alignment of back support in the Left viewport
 

Creating Leg Supports
Now, you will create leg support.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; the Standard

Primitives is displayed in the drop-down list. Next, choose the Box tool in the Object Type



rollout.
 
2. In the Keyboard Entry rollout, set the parameters as follows:
 
Length: 36.677 Width: 9.0 Height: 2.8
 
3. Choose the Create button from the Keyboard Entry rollout; the box is created.
 
4. Name the box as leg support001 and change its color to black.
 
5. Choose the Select and Move tool and align leg support001 to the extreme left and below

horizontal seat support in all viewports, refer to Figure 2-83.
 

Next, you need to copy leg support001 to create the leg support on the right side of horizontal seat
support.

 
6. Activate the Top viewport by middle-clicking in it and create a copy of leg support001 as

described earlier. It is automatically named as leg support002.
 
7. Choose the Select and Move tool and align leg support002 to horizontal seat support in all

viewports, as shown in Figure 2-84.
 
Next, you need to create another box for other leg supports.
 

Figure 2-83 Alignment of leg support001 with horizontal seat support
 



Figure 2-84 Alignment of leg support002 with horizontal seat support
 

8. Activate the Top viewport and create a box using the values as follows:
 
Length: 9.0 Width: 124 Height: 2.8

9. In the Name and Color rollout, name the box as leg support003 and change its color to black.
 
10. Choose the Select and Move tool and align leg support003 with horizontal seat support in all

viewports, as shown in Figure 2-85.
 

Figure 2-85 Alignment of leg support003 with horizontal seat support in viewports
 

Note
You need to use the Arc Rotate tool to view leg support003 properly in the Perspective viewport.
 
11. Create a copy of leg support003 in the Top viewport; it is automatically named as leg

support004.
 
12. Choose the Select and Move tool and align leg support004 with horizontal seat support in all

viewports, refer to Figure 2-86.
 



Creating Rivets for the Seat Support
To create the rivets for horizontal seat support, you need to copy right side rivets. As you already
know that right side rivets are grouped under back support, therefore first you need to open this
group to access them independently. After opening, back support group will be ungrouped
temporarily and you can transform the objects within it independently.
 
1. Activate the Left viewport and select back support.

2. Choose Group > Open from the menu bar; back support is now ungrouped temporarily. Also, a
pink colored bounding box is displayed around back support.

Figure 2-86 Alignment of leg support004 in viewports
 

3. Choose the Select By Name tool; the Select From Scene dialog box is displayed.
 
4. In the Select From Scene dialog box, select right side rivets and choose the OK button, refer to

Figure 2-87.

Figure 2-87 The right side rivets group selected in the Select From Scene dialog box
 
5. Make sure right side rivets group is still selected. Now, create a copy of right side rivets and

name it as right side seat rivets, as shown in Figure 2-88.
 
6. Make sure that right side seat rivets group is selected and choose Group > Detach from the menu

bar; right side seat rivets group is detached from back support group.
 
7. Select the pink colored gizmo of back support group and choose Group > Close from the menu bar



to group them again.
 
Next, you need to align right side seat rivets group.
 
8. Choose the Select and Rotate tool and select right side seat rivets in the Left viewport. Then,

move the cursor over the Z-axis. Now, press the left mouse button and drag the cursor in the
counterclockwise direction to rotate right side seat rivets until the angle of rotation in the Z
spinner becomes 80, refer to Figure 2-89.

 

Figure 2-88 The right side seat rivets group in the Left viewport

Figure 2-89 Rotating the right side seat rivets group in the Left viewport
 

9. Choose the Select and Move tool. Now, move the cursor over the vertical axis and then drag the
mouse downward to align right side seat rivets with horizontal seat support, as shown in Figure
2-90.

 
Next, you need to align the rivet (which is near the horizontal back support) to the horizontal seat

support.
 
10. Make sure right side seat rivets group is selected and choose Group > Open from the menu bar

to ungroup them temporarily.
 

11. Select the rivet which is near horizontal back support and choose the Select and Rotate tool.
Move the cursor over the Z-axis. Now, press the left mouse button and drag the cursor in the
clockwise direction to rotate it until the angle of rotation in the Z spinner in the coordinate display
becomes around -15, refer to Figure 2-91.

 



Figure 2-90 Alignment of right side seat rivets in the Left viewport

Figure 2-91 Rotating rivet in the Left viewport
 

12. Choose the Select and Move tool and align all rivets of right side seat rivets group with
horizontal seat support, as shown in Figure 2-92.

Figure 2-92 Alignment of right side seat rivets in the Left viewport
 

13. Make sure that one of the rivets of right side seat rivets group is selected and choose Group >
Close from the menu bar to group them again.

 
Next, you need to copy right side seat rivets to create rivets on the left side of horizontal seat

support.
 
14. Activate the Top viewport and create a copy of right side seat rivets. Name the new group as left

side seat rivets.
 
15. Align left side seat rivets using the Select and Move tool in viewports, as shown in Figure 2-93.

 
Creating Legs of the Park Bench
In this section, you will create legs of the park bench.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; Standard

Primitives is displayed in the drop-down list. Next, choose the Box tool in the Object Type
rollout.

 



Figure 2-93 Alignment of left side seat rivets in viewports
 

2. In the Keyboard Entry rollout, set the values as follows:
 
Length: 4.0 Width: 3.0 Height: 26.88

 
3. Choose the Create button from the Keyboard Entry rollout; a box is created.
 
4. In the Name and Color rollout, name the box as leg001. Also, change its color to black.

 
5. Choose the Select and Move tool and align leg001 with leg support001 in viewports, refer to

Figure 2-94. You need to adjust the viewport to display all objects properly using the Zoom and
Pan View tools.

 
6. Create three copies of leg001 to create three more legs. These are automatically named as leg002,

leg003, and leg004.
 
7. Choose the Select and Move tool and align leg002, leg003, and leg004 in all viewports, as shown

in Figure 2-95.
 
8. Choose the Zoom Extents All tool and modify the view in the Perspective viewport using the

Orbit tool.
 



Figure 2-94 Alignment of leg001 in viewports
 

Figure 2-95 Alignment of legs in viewports
 

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final rendered image of this
scene by downloading the c02_3dsmax_2015_rndr.zip file from www.cadcim.com. The path of the
file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2015:
A Comprehensive Guide
 
1. Change the background color of the scene to white as discussed in Tutorial 1.
 
2. Choose Save from the Application menu.
 
3. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the Rendered Frame window is displayed. This window shows the final output of the
scene, refer to Figure 2-96.

 

Figure 2-96 The final output after rendering
 

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this


